Ravencoin News:
**IMPORTANT**

Recommended Wallet Update (2.0.4.1)

Several blockchain projects have been attacked via the "CVE-2018-17144" exploit. Ravencoin fixed this bug in the 2.0.4.1 wallet update. Make sure you've upgraded.

(click here to find the latest Ravencoin releases)

Start New Topic

Ravencoin

Alternate Cryptocurrencies

Economics

Community

Off-Topic

Local